La Bibliometría y Excel un matrimonio complicado IV

Bien luego de un tiempo en el que no he publicado nada sobre esta temática retomamos y hoy veremos como realizar un muestreo aleatorio en Excel.

Para esto Excel nos provee la función ALEATORIO que nos genera números entre 0 y 1, para obtener valores enteros utilizamos la función REDONDEAR.
Veremos la fórmula que nos suministraron en el curso =REDONDEAR(ALEATORIO()*nnnn+1;0)
Siendo nnnn el universo sobre el que se aplicara la fórmula.

De modo que si por ejemplo deseamos sortear 50 ejemplares de un total de 1000, debemos aplicar la fórmula: =REDONDEAR(ALEATORIO()1000+1;0) en las 50 primeras celdas.
Ahora bien esta fórmula presenta varios problemas uno debemos generar un índice para luego asociar los números sorteados de dicho índice con los valores verdaderos y nos devuelve números repetidos y en nuestro caso no deseamos esto, en una muestra pequeña podemos pulsar F9 hasta que visualicemos que no tenemos resultados duplicados pero en una muestra grande esto no es viable. La solución a esto es la siguiente: utilizaremos la formula INDICE y JERARQUIA


Vamos a un caso práctico, sobre un universo de 18 itéms, tomaremos una muestra de 9.
A
B
1Cant. Prést.Muestra
2150=INDICE($A$1:$A$18;JERARQUIA(A2;$A$1:$A$18))
3100=INDICE($A$1:$A$18;JERARQUIA(A3;$A$1:$A$18))
4400=INDICE($A$1:$A$18;JERARQUIA(A4;$A$1:$A$18))
5200=INDICE($A$1:$A$18;JERARQUIA(A5;$A$1:$A$18))
6150=INDICE($A$1:$A$18;JERARQUIA(A6;$A$1:$A$18))
7300=INDICE($A$1:$A$18;JERARQUIA(A7;$A$1:$A$18))
8500=INDICE($A$1:$A$18;JERARQUIA(A8;$A$1:$A$18))
9800=INDICE($A$1:$A$18;JERARQUIA(A9;$A$1:$A$18))
10200=INDICE($A$1:$A$18;JERARQUIA(A10;$A$1:$A$18))
1150
1280
130
14200
15180
16300
17250
1895
19120

Luego del sorteo se procederá a estudiar lo que deseamos sobre la muestra.

*Debemos aclarar que las funciones aleatorias en Excel son volátiles, lo que significa que vuelven a sortearse cada vez que se realiza una operación, por esa razón es que pulsando F9 se re sortean los números si utilizáramos la función que vimos en el curso =REDONDEAR(ALEATORIO()*nnnn+1;0)
Por lo mismo una vez realizado el sorteo si se opta por esa función es conveniente copiar el resultado y hacer un "pegado especial" en otras celdas.


Bien en la próxima observaremos los resultados.

Ver entradas todas las entradas de este tema aquí -->

Comentarios